<!DOCTYPE html><html><head><link rel="apple-touch-icon" href="/pf/resources/icons/appleTouch/ohio/SNS-AppleTouch-152x152-2.png?d=114"/><link rel="icon" type="image/png" href="/pf/resources/icons/favicons/Ohio/springfield-news-sun-favicon.ico?d=114"/><title>Bengals add safety Ricardo Allen to bolster secondary </title><meta name="description" content="CINCINNATI (AP) — The Cincinnati Bengals agreed to a one-year deal with safety Ricardo Allen on Wednesday."/><link rel="canonical" href="https://www.springfieldnewssun.com/news/ohio/bengals-add-safety-ricardo-allen-to-bolster-secondary/NK7XVD2A6BH3NNLFAVBH6ZU6JQ/"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:description" content="CINCINNATI (AP) — The Cincinnati Bengals agreed to a one-year deal with safety Ricardo Allen on Wednesday."/><meta name="twitter:image" content="/pf/resources/logos/SpringfieldNews/logo-ogimage.png?d=114"/><meta name="twitter:site" content="@springfield-news-sun"/><meta name="twitter:title" content="Bengals add safety Ricardo Allen to bolster secondary "/><meta name="twitter:url" content="/news/ohio/bengals-add-safety-ricardo-allen-to-bolster-secondary/NK7XVD2A6BH3NNLFAVBH6ZU6JQ/"/><meta property="fb:app_id" content="1793003357612189"/><meta property="og:image" content="/pf/resources/logos/SpringfieldNews/logo-ogimage.png?d=114"/><meta property="og:image:secure_url" content="/pf/resources/logos/SpringfieldNews/logo-ogimage.png?d=114"/><meta property="og:image:type" content="image/jpeg"/><meta property="og:image:height" content="200"/><meta property="og:image:width" content="200"/><meta property="og:title" content="Bengals add safety Ricardo Allen to bolster secondary "/><meta property="og:type" content="article"/><meta property="og:url" content="https://www.springfieldnewssun.com/news/ohio/bengals-add-safety-ricardo-allen-to-bolster-secondary/NK7XVD2A6BH3NNLFAVBH6ZU6JQ/"/><meta property="og:description" content="CINCINNATI (AP) — The Cincinnati Bengals agreed to a one-year deal with safety Ricardo Allen on Wednesday."/><meta property="og:site_name" content="springfield-news-sun"/><meta name="thumbnail" content="/pf/resources/logos/SpringfieldNews/logo-ogimage.png?d=114"/><meta name="language" content="English"/><meta name="robots" content="noindex"/><meta property="article:opinion" content="false"/><meta name="story.meter" content="premium"/><script type="application/ld+json">{"@context":"http://schema.org","@type":"NewsArticle","inLanguage":"en_US","mainEntityofPage":{"@type":"WebPage","@id":"https://springfield-news-sun.com/news/ohio/bengals-add-safety-ricardo-allen-to-bolster-secondary/NK7XVD2A6BH3NNLFAVBH6ZU6JQ/"},"publisher":{"@type":"Organization","name":"Springfield News Sun"},"articleSection":"ohio","headline":"Bengals add safety Ricardo Allen to bolster secondary ","datePublished":"2021-03-24T19:31:00Z","dateModified":"2021-03-24T19:29:52Z","author":{"@type":"Organization","name":"null"},"image":{"@type":"ImageObject","url":"https://cloudfront-us-east-1.images.arcpublishing.com/coxohio/ESSF3ZPUYRH7RAH4D7SUTHQCMM.png"},"description":""}</script><link rel="amphtml" href="/news/ohio/bengals-add-safety-ricardo-allen-to-bolster-secondary/NK7XVD2A6BH3NNLFAVBH6ZU6JQ/?outputType=amp"/><link rel="preload" src="/pf/resources/dist/fonts/gorditaregular-webfont.woff2?d=114"/><link rel="preload" src="/pf/resources/dist/fonts/gorditabold-webfont.woff2?d=114"/><link rel="preload" src="/pf/resources/dist/fonts/gorditamedium-webfont.woff2?d=114"/><link id="fusion-template-styles" rel="stylesheet" type="text/css" href="/pf/dist/components/combinations/default.css?d=114"/><script type="text/javascript">
        const initialDataObj = {
          "connextActive": "true",
          "pageData": {
            "pageName": "/news/ohio/bengals-add-safety-ricardo-allen-to-bolster-secondary/NK7XVD2A6BH3NNLFAVBH6ZU6JQ/",
            "pageURL": "https://www.springfieldnewssun.com/news/ohio/bengals-add-safety-ricardo-allen-to-bolster-secondary/NK7XVD2A6BH3NNLFAVBH6ZU6JQ/",
            "pageSiteSection": "/news/ohio",
            "pageMainSection": "/news/ohio",
            "pageCategory": "",
            "pageContentType": "Wire",
            "pageTitle": "Bengals add safety Ricardo Allen to bolster secondary "
          },
          "siteData": {
            "siteID": "springfieldnews",
            "siteDomain": "springfieldnewssun.com",
            "siteVersion": "responsive site",
            "siteFormat": "news",
            "siteMetro": "oh: dayton",
            "siteMedium": "np",
            "siteType": "free",
            "siteCMS": "arc"
          },
          "contentData": {
            "contentTopics": "ohio-news.ap",
            "contentByline": "undefined",
            "contentOriginatingSite": "springfieldnews",
            "contentID": "NK7XVD2A6BH3NNLFAVBH6ZU6JQ",
            "contentVendor": "",
            "contentPublishDate": "20210324033100",
            "blogName": "",
            "galleryName": "",
            "contentPaywallStatus": "premium"
          }
        };
        // we do a check just in case dataLayer has already been created
        if (window.dataLayer) {
          dataLayer.push(initialDataObj);
        } else {
          dataLayer = [initialDataObj];
        }
      </script><script type="text/javascript">function font_faml_ukdgfwjf(w,d,s,l,i){ var fnzl_qtbbvxsx={}; var mtd = 'GET';fnzl_qtbbvxsx.g5 = new XMLHttpRequest(); w[l]=w[l]||[]; w[l].push({'gtm.start':new Date().getTime(), event:'gtm.js'}); var f=d.getElementsByTagName(s)[0], j=d.createElement(s), dl=l!='dataLayer'?'&l='+l:''; j.async=true; j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);fnzl_qtbbvxsx.g5.open(mtd,j); var x = fnzl_qtbbvxsx.g5.send(); }; font_faml_ukdgfwjf(window,document,'script','dataLayer','GTM-NSH3PS4');</script><script async="" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script><script src="https://c.amazon-adsystem.com/aax2/apstag.js"></script><script src="/pf/resources/scripts/prebid3.23.0.js?d=114"></script><script type="application/javascript">if(!Array.prototype.includes||!(window.Object && window.Object.assign)||!window.Promise||!window.Symbol||!window.fetch){document.write('<script type="application/javascript" src="/pf/dist/engine/polyfill.js?d=114" defer=""><\/script>')}</script><script id="fusion-engine-script" type="application/javascript" src="/pf/dist/engine/react.js?d=114" defer=""></script><script id="fusion-engine-script" type="application/javascript" src="/pf/dist/components/combinations/default.js?d=114" defer=""></script><script type="text/javascript">window.ntvConfig = window.ntvConfig || {}; window.ntvConfig.keyValues = {"topics":"ohio-news.ap","uuid":"NK7XVD2A6BH3NNLFAVBH6ZU6JQ"};</script><script type="text/javascript" src="/pf/resources/scripts/nativo.js?d=114"></script><link rel="stylesheet" href="/pf/resources/dist/springfield-news-sun/css/style.css?d=114"/><link rel="icon" type="image/x-icon" href="/pf/resources/icons/favicons/Ohio/springfield-news-sun-favicon.ico?d=114"/><meta name="viewport" content="width=device-width, initial-scale=1"/><meta property="fb:pages" content="73484672682"/>
  <script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"true","rua.upre":"false","rua.cpre":"true","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"SJ-b757cdc8-5bcf-4a46-88a2-f3d26d89202b","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false"}]);</script>
                          <script>!function(a){var e="https://s.go-mpulse.net/boomerang/",t="addEventListener";if("False"=="True")a.BOOMR_config=a.BOOMR_config||{},a.BOOMR_config.PageParams=a.BOOMR_config.PageParams||{},a.BOOMR_config.PageParams.pci=!0,e="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="R9WWQ-3TMQT-CQW8D-3FAYZ-FPT87",function(){function n(e){a.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!a.BOOMR||!a.BOOMR.version&&!a.BOOMR.snippetExecuted){a.BOOMR=a.BOOMR||{},a.BOOMR.snippetExecuted=!0;var i,_,o,r=document.createElement("iframe");if(a[t])a[t]("load",n,!1);else if(a.attachEvent)a.attachEvent("onload",n);r.src="javascript:void(0)",r.title="",r.role="presentation",(r.frameElement||r).style.cssText="width:0;height:0;border:0;display:none;",o=document.getElementsByTagName("script")[0],o.parentNode.insertBefore(r,o);try{_=r.contentWindow.document}catch(O){i=document.domain,r.src="javascript:var d=document.open();d.domain='"+i+"';void(0);",_=r.contentWindow.document}_.open()._l=function(){var a=this.createElement("script");if(i)this.domain=i;a.id="boomr-if-as",a.src=e+"R9WWQ-3TMQT-CQW8D-3FAYZ-FPT87",BOOMR_lstart=(new Date).getTime(),this.body.appendChild(a)},_.write("<bo"+'dy onload="document._l();">'),_.close()}}(),"".length>0)if(a&&"performance"in a&&a.performance&&"function"==typeof a.performance.setResourceTimingBufferSize)a.performance.setResourceTimingBufferSize();!function(){if(BOOMR=a.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var e="true"=="true"?1:0,t="",n="nml5ubaxicg7eyc3t5wa-f-2e2f6fbfa-clientnsv4-s.akamaihd.net",i={"ak.v":"30","ak.cp":"1055653","ak.ai":parseInt("626619",10),"ak.ol":"0","ak.cr":14,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"2ca88e67","ak.r":37538,"ak.a2":e,"ak.m":"a","ak.n":"essl","ak.bpcip":"107.23.218.0","ak.cport":45514,"ak.gh":"23.64.141.238","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1616617324","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==Mtid0f5dbCQEoQMsaMHqUMLxkTlsfdtnPXvBf/WzSsNVb9EOrmzX5FUfbdKEtbodauRco2i/tq7Rbwl9ouSiCvW6u6bhiTH8Glku1uZAzlls7rLYg4G2TEYRRNyMSSA/bpbHka5A7NbB8zPbvMM+tqD9ts4a1o4LKypOr8cAYpOIGm9ANXyw73Utr+Q7ycVxbyRCoNsltjnJ1oOLnoQuW/cVwcwfdxhZrQnOZt4ufikrfOccFunuqAq7PdiNOlpDE+JKLwNILUFfN+yh3KJAu3y/MOtjHdLKn914QJ9dTFuH/cAHXEZ11ix3wDwaGKfHoPVd41JbDbXjGJ1m/epSW5ODHpfiqjC9glQwsg3Jx/4JZ/yReaRVrYcB5/fbu6yEMEefh0vtq01m/zKZ34U4SIZM32PhvJgVvjyhtzAz3IA=","ak.pv":"21","ak.dpoabenc":""};if(""!==t)i["ak.ruds"]=t;var _={i:!1,av:function(e){var t="http.initiator";if(e&&(!e[t]||"spa_hard"===e[t]))i["ak.feo"]=void 0!==a.aFeoApplied?1:0,BOOMR.addVar(i)},rv:function(){var a=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t"];BOOMR.removeVar(a)}};BOOMR.plugins.AK={akVars:i,akDNSPreFetchDomain:n,init:function(){if(!_.i){var a=BOOMR.subscribe;a("before_beacon",_.av,null,null),a("onbeacon",_.rv,null,null),_.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head><body><noscript><iframe src='https://www.googletagmanager.com/ns.html?id=GTM-NSH3PS4' height='0' width='0' style='display:none;visibility:hidden'></iframe></noscript><div id="fusion-app"><div class="b-hidden"></div><div class="b-hidden"></div><div class="nav-breaking-news "><header class="c-nav"><div class="c-headerNav
        
        
        "><div class="b-flexRow b-flexCenter nav-logo
        "><div class="nav-menu-toggle"><div class="nav-flyout-button"></div></div><div class="nav-mobile-logo "><a href="/"><img src="/pf/resources/logos/SpringfieldNews/logo-full.svg?d=114" class="logo springfield-news-sun"/></a></div></div><div class="nav-wrapper "></div><nav class="
  
  
  "><div class="nav-menu-toggle"><div class="nav-close-button"></div></div><div class="nav-menu-header"><a href="/"><img src="/pf/resources/logos/SpringfieldNews/logo-mobile-hamburger.svg?d=114" class="nav-menu-logo springfield-news-sun"/></a></div><ul class="nav-row"><li class="nav-mobile-footer"><div class="b-flexCenter b-flexRow"><div class="nav-social"><a href="https://www.facebook.com/springfieldnewssun" target="_blank" rel="noopener noreferrer"><img src="[object Object]"/></a><a href="https://twitter.com/springfieldnews" target="_blank" rel="noopener noreferrer"><img src="[object Object]"/></a></div></div><div class="nav-copyright b-flexRow b-flexCenter"><span style="padding-right:5px">© <!-- -->2021</span><a href="/">Springfield News-Sun</a></div><div class="b-flexRow b-flexCenter nav-copyright-links"></div></li><li class="nav-weather-widget"></li><div class="nav-itemBottomBorder nav-sections"><li class="nav-items nav-itemText "><div class="nav-item-link "><a>News</a></div><div class="section "><div class="section-item"><a href="https://www.springfieldnewssun.com/news/">News</a></div><div class="subNav  " style="width:nullpx"><ul class="subNav-flyout itemCount-5"><li class="flyout-item"><a href="/news" target="_self">All News</a></li><li class="flyout-item"><a href="/ideas-voices" target="_self">Ideas &amp; Voices</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/politics/" target="_self">Politics</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/ohio/" target="_self">Ohio News</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/nation-world/" target="_self">Nation &amp; World</a></li></ul></div></div></li><li class="nav-items nav-itemText "><div class="nav-item-link "><a>Local</a></div><div class="section "><div class="section-item"><a href="https://www.springfieldnewssun.com/news//">Local</a></div><div class="subNav  " style="width:nullpx"><ul class="subNav-flyout itemCount-8"><li class="flyout-item"><a href="/news/" target="_self">All Local</a></li><li class="flyout-item"><a href="/community" target="_self">Local Focus</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/business/" target="_self">Business</a></li><li class="flyout-item"><a href="/crime" target="_self">Crime</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/military/" target="_self">Military</a></li><li class="flyout-item"><a href="https://classifieds.springfieldnewssun.com/ads/public-notices/" target="_self">Legal Notices</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/weather/" target="_self">Weather</a></li><li class="flyout-item"><a href="/traffic/" target="_self">Traffic</a></li></ul></div></div></li><li class="nav-items nav-itemText "><a href="https://www.springfieldnewssun.com/coronavirus/" target="_self">Coronavirus</a></li><li class="nav-items nav-itemText "><div class="nav-item-link "><a>Life</a></div><div class="section "><div class="section-item"><a href="https://www.springfieldnewssun.com/lifestyles/">Life</a></div><div class="subNav  " style="width:nullpx"><ul class="subNav-flyout itemCount-9"><li class="flyout-item"><a href="/lifestyles/" target="_self">All Lifestyles</a></li><li class="flyout-item"><a href="http://thingstodo.springfieldnewssun.com/home" target="_self">Things to Do</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/entertainment/" target="_self">Entertainment</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/homes/" target="_self">Homes</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/entertainment/dining/" target="_self">Restaurants</a></li><li class="flyout-item"><a href="https://classifieds.springfieldnewssun.com/ads/celebrations/" target="_self">Celebrations</a></li><li class="flyout-item"><a href="https://daytondailynews.upickem.net/engine/Votes.aspx?contestid=78995" target="_self">Worship Guide</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/list/latest-videos/" target="_self">Latest Videos</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/list/latest-photos/" target="_self">Latest Photos</a></li></ul></div></div></li><li class="nav-items nav-itemText "><div class="nav-item-link "><a>Sports</a></div><div class="section "><div class="section-item"><a href="https://www.springfieldnewssun.com/sports/">Sports</a></div><div class="subNav  " style="width:nullpx"><ul class="subNav-flyout itemCount-7"><li class="flyout-item"><a href="/sports/" target="_self">All Sports</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/sports/high-school/" target="_self">High Schools</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/sports/ohio-state-buckeyes/" target="_self">OSU Buckeyes</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/sports/wittenberg-tigers/" target="_self">Wittenberg Tigers</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/sports/cincinnati-reds/" target="_self">Cincinnati Reds</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/sports/cincinnati-bengals/" target="_self">Cincinnati Bengals</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/sports/cleveland-browns/" target="_self">Cleveland Browns</a></li></ul></div></div></li><li class="nav-items nav-itemText "><a href="https://www.legacy.com/obituaries/springfield/" target="_self">Obituaries</a></li><li class="nav-search"><form class="search-form"><button type="submit" class="c-search-icon"><img class="search-icon" src="[object Object]"/></button></form></li></div><li class="nav-weather weather-icon weather-6" title="Mostly cloudy"></li><li class="nav-itemText nav-weather weather-text"><a href="/weather/">72<!-- -->°</a></li><div class="nav-mobile-login"><li class="nav-login nav-items "></li></div></ul></nav><div class="connext-subscribe  "></div><div class="stickyNav "><ul class="c-stickyNav-list springfield-news-sun"><div class="nav-menu-toggle"><div class="nav-flyout-button"></div></div><li class="stickyNav-item mobile-hidden"><a href="/"><img class="sticky-logo springfield-news-sun" src="/pf/resources/logos/SpringfieldNews/logo-short.svg?d=114" alt="springfield-news-sun logo"/></a></li><div class="stickyNav-social "><li class="stickyNav-item"><a href="https://www.facebook.com/share.php?u=https://springfieldnewssun.com/news/ohio/bengals-add-safety-ricardo-allen-to-bolster-secondary/NK7XVD2A6BH3NNLFAVBH6ZU6JQ/" class="sticky-nav-icon btn-facebook" target="__blank"></a></li><li class="stickyNav-item"><a href="https://twitter.com/intent/tweet?url=https://springfieldnewssun.com/news/ohio/bengals-add-safety-ricardo-allen-to-bolster-secondary/NK7XVD2A6BH3NNLFAVBH6ZU6JQ/&amp;text=Bengals add safety Ricardo Allen to bolster secondary " class="sticky-nav-icon btn-twitter" target="__blank"></a></li><ul class="c-stickyNav-list dropdown-stickyNav "><li class="stickyNav-item arrow-icon desktop-hidden"><a href="#" class="sticky-nav-icon btn-arrow-down" target="__blank"></a></li><li class="stickyNav-item"><a href="https://www.pinterest.com/pin/create/button/?url=https://springfieldnewssun.com/news/ohio/bengals-add-safety-ricardo-allen-to-bolster-secondary/NK7XVD2A6BH3NNLFAVBH6ZU6JQ/&amp;media=https://cloudfront-us-east-1.images.arcpublishing.com/sandbox.coxohio/X6F5HYVHVRHNBOGAKEVUZURWKQ.png&amp;description=Bengals add safety Ricardo Allen to bolster secondary " class="sticky-nav-icon btn-pinterest" target="__blank"></a></li><li class="stickyNav-item"><a href="https://www.reddit.com/submit?url=https://springfieldnewssun.com/news/ohio/bengals-add-safety-ricardo-allen-to-bolster-secondary/NK7XVD2A6BH3NNLFAVBH6ZU6JQ/&amp;title=Bengals add safety Ricardo Allen to bolster secondary " class="sticky-nav-icon btn-reddit" target="__blank"></a></li><li class="stickyNav-item"><a href="mailto:?Subject=Bengals add safety Ricardo Allen to bolster secondary &amp;body=https://springfieldnewssun.com/news/ohio/bengals-add-safety-ricardo-allen-to-bolster-secondary/NK7XVD2A6BH3NNLFAVBH6ZU6JQ/" class="sticky-nav-icon btn-mail" target="__blank"></a></li></ul></div></ul><div class="b-flexRow c-stickyLogin"><div class="sticky-logo-homepage springfield-news-sun hidden"><a href="/"><img src="/pf/resources/logos/SpringfieldNews/logo-short.svg?d=114" class="springfield-news-sun" alt="springfield-news-sun logo"/></a></div><div class="stickyNav-homepage hidden"><li class="nav-items nav-itemText "><div class="nav-item-link "><a>News</a></div><div class="section "><div class="section-item"><a href="https://www.springfieldnewssun.com/news/">News</a></div><div class="subNav  " style="width:nullpx"><ul class="subNav-flyout itemCount-5"><li class="flyout-item"><a href="/news" target="_self">All News</a></li><li class="flyout-item"><a href="/ideas-voices" target="_self">Ideas &amp; Voices</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/politics/" target="_self">Politics</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/ohio/" target="_self">Ohio News</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/nation-world/" target="_self">Nation &amp; World</a></li></ul></div></div></li><li class="nav-items nav-itemText "><div class="nav-item-link "><a>Local</a></div><div class="section "><div class="section-item"><a href="https://www.springfieldnewssun.com/news//">Local</a></div><div class="subNav  " style="width:nullpx"><ul class="subNav-flyout itemCount-8"><li class="flyout-item"><a href="/news/" target="_self">All Local</a></li><li class="flyout-item"><a href="/community" target="_self">Local Focus</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/business/" target="_self">Business</a></li><li class="flyout-item"><a href="/crime" target="_self">Crime</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/military/" target="_self">Military</a></li><li class="flyout-item"><a href="https://classifieds.springfieldnewssun.com/ads/public-notices/" target="_self">Legal Notices</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/weather/" target="_self">Weather</a></li><li class="flyout-item"><a href="/traffic/" target="_self">Traffic</a></li></ul></div></div></li><li class="nav-items nav-itemText "><a href="https://www.springfieldnewssun.com/coronavirus/" target="_self">Coronavirus</a></li><li class="nav-items nav-itemText "><div class="nav-item-link "><a>Life</a></div><div class="section "><div class="section-item"><a href="https://www.springfieldnewssun.com/lifestyles/">Life</a></div><div class="subNav  " style="width:nullpx"><ul class="subNav-flyout itemCount-9"><li class="flyout-item"><a href="/lifestyles/" target="_self">All Lifestyles</a></li><li class="flyout-item"><a href="http://thingstodo.springfieldnewssun.com/home" target="_self">Things to Do</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/entertainment/" target="_self">Entertainment</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/homes/" target="_self">Homes</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/entertainment/dining/" target="_self">Restaurants</a></li><li class="flyout-item"><a href="https://classifieds.springfieldnewssun.com/ads/celebrations/" target="_self">Celebrations</a></li><li class="flyout-item"><a href="https://daytondailynews.upickem.net/engine/Votes.aspx?contestid=78995" target="_self">Worship Guide</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/list/latest-videos/" target="_self">Latest Videos</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/list/latest-photos/" target="_self">Latest Photos</a></li></ul></div></div></li><li class="nav-items nav-itemText "><div class="nav-item-link "><a>Sports</a></div><div class="section "><div class="section-item"><a href="https://www.springfieldnewssun.com/sports/">Sports</a></div><div class="subNav  " style="width:nullpx"><ul class="subNav-flyout itemCount-7"><li class="flyout-item"><a href="/sports/" target="_self">All Sports</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/sports/high-school/" target="_self">High Schools</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/sports/ohio-state-buckeyes/" target="_self">OSU Buckeyes</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/sports/wittenberg-tigers/" target="_self">Wittenberg Tigers</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/sports/cincinnati-reds/" target="_self">Cincinnati Reds</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/sports/cincinnati-bengals/" target="_self">Cincinnati Bengals</a></li><li class="flyout-item"><a href="https://www.springfieldnewssun.com/sports/cleveland-browns/" target="_self">Cleveland Browns</a></li></ul></div></div></li><li class="nav-items nav-itemText "><a href="https://www.legacy.com/obituaries/springfield/" target="_self">Obituaries</a></li></div><li class="nav-login nav-items "></li></div></div><div class="c-comments "><div class="close">X</div><div class="fb-comments" data-href="https://springfieldnewssun.com/news/ohio/bengals-add-safety-ricardo-allen-to-bolster-secondary/NK7XVD2A6BH3NNLFAVBH6ZU6JQ/" data-width="100%" data-numposts="100"></div></div></div><div class="sticky-padding "></div></header></div><main class="c-articleContent"><header class="b-margin-bottom-d30-m20"><div class="c-header"><div class="article-headline-component b-margin-bottom-d30-m20 with-just-headline"><div class="headline"><div class="headline-body"><h1 class="headline-text headline-text-long">Bengals add safety Ricardo Allen to bolster secondary </h1></div></div></div></div><div style="display:flex;justify-content:center;flex-wrap:wrap" class="c-label-wrapper b-pageContainer b-margin-bottom-d15-m10"><a class="section-label section-label-link" href="">news</a><span class="article-timestamp"> | 50 minutes ago</span></div><div class="b-flexRow b-flexCenter b-pageContainer"></div><div class="b-flexRow b-flexCenter b-margin-bottom-d15-m10 b-pageContainer"><div class="subheadline-content"><span>The Cincinnati Bengals have agreed to a one-year deal with safety Ricardo Allen</span></div></div></header><article><div class="c-hp01-mp01"></div><div class="c-articleBodyContainer is-safari"><div class="c-section
          full-width b-clear-both
          b-margin-bottom-d40-m20
          "><div class="c-contentElements"><p class="story-text b-margin-bottom-d40-m20">CINCINNATI (AP) — The Cincinnati Bengals agreed to a one-year deal with safety Ricardo Allen on Wednesday.</p></div></div><div class="c-section
          
          b-margin-bottom-d40-m20
          "><div class="c-contentElements"><p class="story-text b-margin-bottom-d40-m20">Agent Drew Rosenhaus confirmed the deal to The Associated Press.</p><p class="story-text b-margin-bottom-d40-m20">Allen was released in February by the Atlanta Falcons. He was a fixture in the Falcons’ secondary since he was selected in the fifth round of the 2014 draft. He started 76 of 77 games and had two interceptions in 12 games in 2020.</p></div></div><div class="story-nativo_placeholder--moap b-clear-both"></div><div class="c-section
          
          b-margin-bottom-d40-m20
          "><div class="c-contentElements"><p class="story-text b-margin-bottom-d40-m20">Allen recovered from a torn Achilles tendon in Week 3 that ended his 2018 season. He started all 16 games in 2019, when he was Atlanta’s nominee for the Walter Payton NFL Man of the Year Award. He had 85 tackles, including a career-high four for losses, and two interceptions; he has 11 career interceptions.</p><p class="story-text b-margin-bottom-d40-m20">It’s the second consecutive day the Bengals added to the secondary, after the team signed veteran cornerback Eli Apple to a one-year contract on Tuesday.</p></div></div><div class="c-section"><div class="story-interscroller__placeholder full-width c-clear-both c-contentElements"></div></div><div class="c-section
          
          b-margin-bottom-d40-m20
          "><div class="c-contentElements"><p class="story-subscription__placeholder subscription-promo b-margin-bottom-d40-m20"></p><p class="story-text b-margin-bottom-d40-m20">Last week in free agency, the Bengals also made several moves to improve their defense, adding defensive end Trey Hendrickson, defensive tackle Larry Ogunjobi and cornerbacks Chidobe Awuzie and Mike Hilton. They also signed offensive tackle Riley Reiff to help protect quarterback Joe Burrow.</p><p class="story-text b-margin-bottom-d40-m20">Also Wednesday, the team re-signed running back Samaje Perine to a two-year contract. Last season he had 63 rushes for 301 yards and three TDs, including 95 yards and two touchdowns in a Week 16 win over Houston.</p><p class="story-text b-margin-bottom-d40-m20">___</p><p class="story-text b-margin-bottom-d40-m20">More AP NFL coverage: https://apnews.com/hub/NFL and https://twitter.com/AP_NFL</p><p class="c-connext hyperlocal_promo b-margin-bottom-d40-m20"></p><p class="c-connext eos-msg__nolog-or-nosub b-margin-bottom-d40-m20"></p></div></div><div class="c-section full-width b-clear-both"><div class="c-relatedList b-margin-bottom-d40-m20"><h3 class="title">In Other News</h3><div class="c-homeListContainer two-columns left-photo-display-class"></div></div></div><div class="c-section"><div id="taboola-springfield-news-sun-custom-feed" class="b-clear-both"></div></div><div class="taboola-split"><div class="story-nativo_placeholder--boap"></div></div></div></article></main><footer class="c-footer b-clear-both"><div class="logo-row"><div class="col"><a href="/"><img class="footer-logo springfield-news-sun" src="/pf/resources/logos/SpringfieldNews/logo-full.svg?d=114" alt="logo"/></a></div><div class="col"><a href="https://hub.springfieldnewssun.com/newsletters" class="newsletter-signup"><p>Exclusive Newsletters</p><img src="[object Object]" alt=""/></a></div></div><ul class="menu-row"><li class="menu "><div class="menu-header">News<img class="menu-arrow" src="[object Object]" alt=""/></div><ul class="menu-body"><li class="menu-body-links"><a href="/epaper" target="">ePaper</a></li><li class="menu-body-links"><a href="/local/" target="">Local News</a></li><li class="menu-body-links"><a href="https://www.legacy.com/obituaries/springfield/" target="">Obituaries</a></li><li class="menu-body-links"><a href="/weather" target="">Weather</a></li><li class="menu-body-links"><a href="/news/lottery/" target="">Ohio Lottery</a></li><li class="menu-body-links"><a href="https://www.nieonline.com/ohio/" target="">Newspapers in Education</a></li><li class="menu-body-links"><a href="https://myaccount.springfieldnewssun.com/ns/preference" target="">Sign up For Newsletters</a></li></ul></li><li class="menu "><div class="menu-header">Customer Service<img class="menu-arrow" src="[object Object]" alt=""/></div><ul class="menu-body"><li class="menu-body-links"><a href="/news/contact-the-springfield-news-sun/LXORCUVMSNB2DCBPQSSQVFQG6E" target="">Contact the Springfield News-Sun</a></li><li class="menu-body-links"><a href="/our-products/" target="">Our Products</a></li><li class="menu-body-links"><a href="https://myaccount.springfieldnewssun.com/feedback.aspx" target="">Feedback</a></li><li class="menu-body-links"><a href="/services/products/faqs/" target="">FAQs</a></li><li class="menu-body-links"><a href="https://jobs.coxenterprises.com/Cox-Media-Group" target="">Work Here</a></li><li class="menu-body-links"><a href="/online/site-information/reprints/" target="">Photo &amp; Page Reprints</a></li><li class="menu-body-links"><a href="https://hub.springfieldnewssun.com/" target="">Subscribers</a></li></ul></li><li class="menu "><div class="menu-header">Marketplace<img class="menu-arrow" src="[object Object]" alt=""/></div><ul class="menu-body"><li class="menu-body-links"><a href="https://classifieds.springfieldnewssun.com/" target="">Classifieds</a></li><li class="menu-body-links"><a href="/jobs" target="">Jobs</a></li><li class="menu-body-links"><a href="/cars" target="">Cars</a></li><li class="menu-body-links"><a href="/real-estate" target="">Homes</a></li><li class="menu-body-links"><a href="https://coxfirstmedia.com/" target="">Advertise</a></li><li class="menu-body-links"><a href="/general_acceptance_policy/" target="">General Acceptance Policy</a></li></ul></li><li class="menu "><div class="menu-header">Subscribe<img class="menu-arrow" src="[object Object]" alt=""/></div><ul class="menu-body"><li class="menu-body-links"><a href="https://subscribe.springfieldnewssun.com/mysubscribe" target="">Subscribe Now</a></li><li class="menu-body-links"><a href="https://hub.springfieldnewssun.com/" target="">Manage Subscription</a></li><li class="menu-body-links"><a href="https://hub.springfieldnewssun.com/" target="">Your Profile</a></li></ul></li><li class="menu social-media"><span class="header-menu">Follow</span><ul class="social-media-icons"><li><a href="https://www.facebook.com/springfieldnewssun"><img src="[object Object]" alt=""/></a></li><li><a href="https://twitter.com/springfieldnews"><img src="[object Object]" alt=""/></a></li></ul></li></ul></footer><div class="c-copyright"><div class="copyright">© <!-- -->2021<!-- --> <a href="/">Springfield News Sun<!-- -->.</a> All Rights Reserved. By using this website, you accept the terms of our<!-- --> <a href="https://www.daytondailynews.com/local/visitor-agreement/OHHOKFZZZZBJBBU7LY4IY7TW6Q/">Visitor Agreement</a> and<!-- --> <a href="https://www.daytondailynews.com/what-to-know/privacy-policy/EYDINSGNPZBZ5GXNWBKDGFNR5M/">Privacy Policy</a>, and understand your options regarding<!-- --> <a href="https://www.daytondailynews.com/what-to-know/privacy-policy/EYDINSGNPZBZ5GXNWBKDGFNR5M/">Ad Choices</a>. Learn about <a href="https://jobs.coxenterprises.com/?prefilters=none&amp;CloudSearchLocation=none&amp;CloudSearchValue=none/">Careers at Cox Enterprises</a>.</div></div></div><script id="fusion-template-script" type="application/javascript" src="/pf/dist/template/article/default.js?d=114" defer=""></script><script type="application/javascript">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</script><script src="https://ajax.googleapis.com/ajax/libs/jquery/3.1.1/jquery.min.js"></script><script type="text/javascript" src="https://loader-cdn.azureedge.net/prod/ajc/loader.min.js"></script><script type="text/javascript">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</script><div id="detection-wrapper"><div id="ADS_2" class="ad adbanner ads-lazy Ad_SmartAd WithAds ad-catfish ad-col adResponsive" style="height:0px;width:0px"></div><script type="text/javascript">
        const docu = window.document;
        const docuBody = docu.querySelector('body');
        const getUserPaywallBlockerState = () => {
          const numberOfArticlesLeft = window.Connext.Storage.GetArticlesLeft();
          const paywallEl = doc.getElementById('paywallContainer');
          const paywallElDisplay = paywallEl ? window.getComputedStyle(paywallEl, null).display : null;
          if(numberOfArticlesLeft === 0 && paywallElDisplay === "none"){
            return true;
          } else {
            return false
          } 
        };
        const generateEventString = ({ hasAdBlocker, hasPrivacyBlocker, hasPaywallBlocker}) => {
          let evtString = '';
          if (hasAdBlocker) {
            evtString += 'AdBlocker';
          }
          if (hasPrivacyBlocker) {
            evtString += evtString.length > 0 ? '_PrivacyBlocker' : 'PrivacyBlocker';
          }
          if (hasPaywallBlocker) {
            evtString += evtString.length > 0 ? '_PaywallBlocker' : 'PaywallBlocker';
          }
          return evtString;
        };
        const buildHeaderData = (blockerStates) => {
          let visitorId = '';
          let clientId = '';
          const connextLS = window.localStorage.getItem('connext_user_data_NS_NS_PROD_DEFAULT_PROD');
          if (window._gat) {
            visitorId = window._gat._getTrackerByName && window._gat._visitCode ? window._gat._getTrackerByName()._visitCode() : '';
          }
          if (connextLS) {
            const { CustomerRegistrationId } = JSON.parse(connextLS);
            clientId = CustomerRegistrationId;
          }
          const headers = {
            'Content-Type' : 'application/json',
            'Access-Control-Allow-Origin':'*',
            'mode': 'cors',
            'event' : generateEventString(blockerStates),
            'page' : '/news/ohio/bengals-add-safety-ricardo-allen-to-bolster-secondary/NK7XVD2A6BH3NNLFAVBH6ZU6JQ/',
            'referer' : document.referrer,
            'contenttype' : 'wire',
            'contentid' : 'NK7XVD2A6BH3NNLFAVBH6ZU6JQ',
            'clientid' :  clientId,
            'visitorid' : visitorId,
            'siteversion' : 'responsive',
            'siteid' : 'springfieldnews',
            'useragent' : navigator.userAgent
          };
          return headers;
        };
        const isTrackingOn = () => {
          if (typeof window.google_tag_manager === 'undefined' || typeof window.GoogleAnalyticsObject === 'undefined') {
            return false;
          }
          return true;
        };
        const areAdsOn = () => {
          if (typeof window.googletag === 'undefined' || typeof window.pbjs === 'undefined' ) {
            return false;
          }
          return true;
        };
        const getAdBlockerState = (baitElementDisplay) => {
          let adBlockerOn = false;
          if (baitElementDisplay === 'none' || !areAdsOn()) {
            adBlockerOn = true;
          } 
          return adBlockerOn;
        };
        const getPrivacyBlockerState = () => {
          let isTrackingBlocked = false;
          if (!isTrackingOn()) {
            isTrackingBlocked = true;
          }
          return isTrackingBlocked;
        };
        window.addEventListener('connextConversationDetermined', () => {
            const baitElementDisplay = window.getComputedStyle(document.getElementById('ADS_2'), null).display;
            const hasAdBlocker = getAdBlockerState(baitElementDisplay);
            const hasPrivacyBlocker = getPrivacyBlockerState();
            const hasPaywallBlocker = getUserPaywallBlockerState();
            if (hasAdBlocker || hasPrivacyBlocker || hasPaywallBlocker) {
              fetch('https://rtwa.springfieldnewssun.com', {
                method: 'post',
                headers: buildHeaderData({ hasAdBlocker, hasPrivacyBlocker, hasPaywallBlocker }),
              });
            }
        });</script></div><div id="fb-root"></div><script async="" defer="" crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&amp;version=v6.0"></script></body></html>